Compatible Versions


TVPlayer is compatible with the following Android devices, which must be running Android 4.2 upwards

To check your Android version is compatible with TVPlayer:

  1. Press Home Button
  2. Select general 'Settings'
  3. Scroll down to the bottom and select About Device
  4. Android version number will be listed

TVPlayer requires Android 4.2 or above to run and will not work on any devices running below Android 4.2 (e.g. 4.1): 



Feedback and Knowledge Base